High Processing Volume
Informational
2026-07-21T14:30:00.0000000Z
High Processing Volume
Status: closed
Date:
2026-07-10T06:33:00.0000000Z
End:
2026-07-21T14:30:00.0000000Z
Duration: 11 days 7 hours 57 minutes
Affected Components:
KYCA
KYCA
Update
2026-07-10T06:33:00.0000000Z
2026-07-10T06:33:00.0000000Z
We're currently experiencing higher than normal document processing volumes. Your documents are in queue and will be processed in the order received. We appreciate your patience during this time.
Resolved
2026-07-21T14:30:00.0000000Z
2026-07-21T14:30:00.0000000Z
Incident involving KYCA is resolved.
For technical issues please contact support at (888) 676-2466