OTP

Incident

OTP

Status: closed
Start:
End:
Duration: 20 days 6 minutes
Affected Components:
KYCA KYCA
Investigating

We are aware of an issue currently affecting OTP delivery. Our Technical Team is working to resolve this as quickly as possible. 

Resolved

Incident involving KYCA is resolved.